[Date Prev]   [Date Next] [Thread Prev]   [Thread Next] [Date Index]   [Thread Index]


     Re: [snips-users] problems with hostmon getting data

On Thu, Mar 27, 2003 at 02:05:33PM +1100, Campbell McLeay wrote:
> Hi,
> I am having troubles in getting hostmon-client to cat data
> out to the server upon connection. Hostmon is generating
> the data fine on the client (and it is readable by user 'snips'),
> but when connecting to the port via telnet on port 5355, it
> doesn't print out the collected data. As such, the server reports:
> server  server        _0001 14:45       DataAge       550  Critical
> Am I correct in assuming that a telnet connection to the hostmon
> port will actually cat the data out? In debug mode, hostmon
> client shows the connection arriving ok, but not catting data. I seem to remember
> that the way to this worked at other installations I have seen
> is to run hostmon-client from inetd, and run cat /tmp/hostmon.tmp
> on connection. But I presume that is not the way it is done any more.
> [...]

I'm finally catching up on the mailing list (been a while since I've
read it regularly), but I didn't see this answered, so...

I'm /guessing/ here that you haven't set SNIPS_LOGHOST in hostman_client.
By default, you should be able to connect to it from localhost (try
doing a "telnet 0 5355" from the host).  My script, for example looks
similar to the following:

-- begin
$SNIPS_LOGHOST = "snips.loosenut.com" unless $SNIPS_LOGHOST;    # SET_THIS
@permithosts = qw( localhost) unless @permithosts;
-- end

Hope that helps...


Russell M. Van Tassell
russell at loosenut com

 "The streets are safe in Philadelphia, it's only the people who make
  them unsafe."                                     -- Mayor Frank Rizzo

Zyrion Traverse Network Monitoring & Network Management Software