[Date Prev]   [Date Next] [Thread Prev]   [Thread Next] [Date Index]   [Thread Index]


     [snips-users] Ippingmon/multiping hanging/crashing

I've been having a problem where multiping seems to sometimes hang and seems to cause ippingmon to hang also. Sometimes ippingmon
completely crashes and keepalive_monitors restarts it. I always get the same error when ippingmon crashes and keepalive_monitors
restarts it (I've removed the list of IP addresses for security reasons):

RESTARTING monitor  ippingmon-CUSTS  on localhost
  Previous error file for ippingmon-CUSTS :

  ippingmon-CUSTS- Reading global config file /usr/local/snips/etc/snips.conf
  (ippingmon-CUSTS).. locked pid-file, started new process (pid=8853)
  ippingmon error- command /usr/local/snips/bin/multiping -qtn -c 5 -s 100  <ip addresses removed> returned !
  ippingmon-CUSTS: removing data, pid file.... Done 

The main problem is when multiping hangs, that ippingmon process will hang also and the devices stop getting updated. I can run the
above (extremely long with the IP addresses) multiping command over and over from the command line with no problems. I'm running 2
ippingmon processes (ippingmon-GBIS and ippingmon-CUSTS), and the other process doesn't seem to have this problem. I'm monitoring
close to the same number of devices in each multiping process (about 100 each). I'm using:
RedHat 8.0
Snips 1.1
I have even tried compiling just the multiping program from snips 1.2beta2 and using it but the problem still happens. Any ideas?

Jeremy Palmer
Network Administration
Great Basin Internet Services
nocstaff at greatbasin net

Zyrion Traverse Network Monitoring & Network Management Software