[Date Prev]   [Date Next] [Thread Prev]   [Thread Next] [Date Index]   [Thread Index]


     Re: [nocol-users] webnocol.cgi

First thing I'd suggest is checking file permissions on
/var/log/datalog.  Is this running as root or some other user?  You can
run an 'id' process to find out what it's actually running as and in
what groups.

On Fri, 18 Dec 1998, Alan Halachmi wrote:

> Quick question...
> 	I'm no PERL wizard, so I'm in need of some help.  I
> added another command to the troubleshooting area of webnocol.
> When I had the webnocol.cgi line read:
> local ($tail) = "tail /var/log/datalog";
> everything worked fine.
> However, when I changed it to:
> local ($tail) = "/usr/bin/grep DEVICE /var/log/datalog | /usr/bin/tail";
> it no longer works.
> I tried:
> local ($tail) = "/usr/bin/grep DEVICE /var/log/datalog"
> but that didn't work either.
> I'd like to be able to take a site, grep it from the datalog file and tail the output of the grep, but I'm not having any luck.
> Ideas?
> TIA,
> Alan
> --
> Alan Halachmi
> Wide Area Networks Specialist
> Ingram Entertainment Network Services
> mailto:alan@halachmi.net
> http://www.ingramentertainment.com

Thank you,

Jonathan A. Zdziarski
Sr. Systems Administrator
Netrail, inc. 
888.NET.RAIL x240