[Date Prev]   [Date Next] [Thread Prev]   [Thread Next] [Date Index]   [Thread Index]


     Problems with radiusmon

Hi all,

I've finally upgraded my NOCOL installation from some ancient beta and
noticed the funky 'radiusmon' monitor, which looks fairly useful.

However, I'm having a little trouble getting to work properly with my
RADIUS server (the Lucent thing that goes with our Portmaster).


I've set up an entry in the 'clients' file for the RADIUS server so it
knows about my NOCOL box and put a corresponding entry in the
'radiusmon-confg' file.  I've defined a 'radtest' user on the RADIUS
server (with a password) and put that stuff in the 'radiusmon-confg' file
too.  I'm pretty sure this stuff is correct...


The RADIUS server is always refusing authentication.  :(

I've tried rebuilding 'radiusmon' so it doesn't care (with -DIGNORE_AUTH
in the Makefile) but this doesn't seem to work.

In desperation, I've tried changing the Service-Type for the radtest user
on the RADIUS server to all the things I can think of, just in case this
was a problem, but this seems to have no effect.

Anyone have any ideas?  I could roll up my sleeves, live and breathe RFCs
etc. for a while and probably come up with the answer but maybe someone's
already done this???  ;-)

Thanks in advance for any help.

Adrian Close					email: 	adrian@aba.net.au
Network Engineer	  			phone:	+61 3 8341 2400
Australian Business Access Pty Ltd		fax:	+61 3 8341 2499
P.O. Box 302, Carlton, VIC, 3053, Australia	web:	http://www.aba.net.au

P.S.  Yes, the RADIUS server does actually work.  It's happily
authenticating logins to our Postmaster as I type.