[Date Prev]   [Date Next] [Thread Prev]   [Thread Next] [Date Index]   [Thread Index]


     [nocol-users] Problems with Trapmon

Hi all!

We use trapmon pretty extensively and I'm having a problem getting trapmon
to produce output into a netconsole display (or anything at all for that
matter).  We have a bunch of machines that run nocol and trapmon works fine.
I have one machine sitting behind our PIX firewall with holes poked in for
SNMP and SNMP traps.   If I run trapmon on the command line with -v -p and
-l I see it receive the trap I generated and it will log it to syslog. See
bash-2.02# ./trapmon -vvv -p -l
options set to 6.
SNMP session opened successfully.
snmp_select_info()... select() == 1... Entered process_trap... [netswitch2.jersey.net]: Enterprise Trap (0) Uptime: 6 days,
20:35:27 Warning
Done with process_trap.
snmp_select_info()... May  8 14:25:06 bsdi1 trapmon:
[netswitch2.jersey.net]: Enterprise Trap (0) Uptime: 6 days, 20:35:27
Warning (Netswitch2 \n)

But when I run trapmon in the background via keepalive_monitors, it never
outputs anything to the nocol/data directory, therefore never shows up on a
netconsole nor pages me.  Anyone have any clue or have had this problem


Jason McMullen