[Date Prev]   [Date Next] [Thread Prev]   [Thread Next] [Date Index]   [Thread Index]


     Re: [nocol-users] APCMON

On Wed, 17 Jan 2001, Nate Sanders wrote:

> I've been trying to get a APC 1400 Smart UPS to work with NOCOL 4.3.1
> for a while now.
> Heres the errors i receive:
> (nocol@fling:~/run)$ tail apcmon.error
> 21050
> Scalar found where operator expected at (eval 59) line 3, within string
>         (Missing operator before ?)
> Scalar found where operator expected at (eval 60) line 3, within string
>         (Missing operator before ?)
> Cannot open UPS serial port /dev/cuaa1: No such file or directory
> (nocol@fling:~/run)$ ls -l /dev/cuaa1
> crw-rw-rw-  1 uucp  dialer   28, 129 Jan 17 11:51 /dev/cuaa1
> ApcUPSD works and says it connects to the UPS with no problems. Why
> could nocol fail? I've tried running Nocol as Root and as user Nocol,
> and tried cuaa0 and cuaa1.
> This is a FreeBSD 2.2.2-RELEASE box. (i386)
> --
> Nate Sanders                       nate@chef.nerp.net
> http://www.damnation.net           IRC: darkskull@NEWNET

Those first two errors appear to be generated by the perl interpretor. 
Meaning... something is probably wrong with the apcmon script syntax.

Try the command:  perl -c /usr/local/nocol/bin/apcmon 

which should give you the complete list of errors in the script.  
(Substitute the actual path for apcmon. of course :) 

Fix the code until you get "apcmon syntax OK" as the result. 

Hope that helps :)

Ken Fischer, CCNA  <kenf@junebug.org>
PGP Fingerprint: 9523 54B6 D67B BBFB 53B3  2F3B 7E81 0891 C495 CB50