[Date Prev]   [Date Next] [Thread Prev]   [Thread Next] [Date Index]   [Thread Index]


     Portmon and POP3?


finally I got it managed to use nocol :-) I use the "stable 4.2.1"
Version, no beta actually. I try to test my POP3 servers with the
portmon, but that won't work. I tried the following:

HOST IIwebPOST 111.222.333.444 POPport 110 Critical
info    +OK POP3 server ready
TIME  30 60 90   +OK POP3 server ready

This is the actual version.

I also tried

HOST IIwebPOST 111.222.333.444 POPport 110 Critical USER rince@test\nPASS abcde\n
info    +OK User logged in, proceed.
TIME  30 60 90   +OK User logged in, proceed.

... but this won't work, at least it gets an error. 
portmon -d brings:

(debug) Connected: 'IIwebPOST:110'
(debug) Looking for any initial connect string
(debug) timeout_read(): Reading a line from socket..
(debug) timeout_read: Read 64 bytes from socket
 (debug) portmon: ignoring connect string '+OK POP3 server ready
 (debug) portmon: host IIwebPOST sent string 'USER
PASS abcde

[waiting a long time]
timeout_read(): select() timed out
read error for 'IIwebPOST:110'- timeout
(debug) elapsed time= 9999 secs
 (debug) checkport(): returning severity 1
(debug) portmon: sleeping for 60...zzz

While this exercise works fine with telnet (just go to port 110 and
authenticate yourself), the portmon can't see it as far as I can
see. Do you know what I am doing wrong?

Ciao, Hanno
i.A. Hanno Wagner, Central Services          Xlink Internet Service GmbH
[X] rince@xlink.net    [X]   Tel: 0721/9652-211  [X]  Fax: 0721/9652-209
[X] Geschaeftsfuehrer: Michael Rotert.    Amtsgericht Karlsruhe HRB 8161.
[X] Auftraege erledigen wir zu unseren Allgemeinen Geschaeftsbedingungen.