[Date Prev]   [Date Next] [Thread Prev]   [Thread Next] [Date Index]   [Thread Index]


     Re: [nocol-users] solaris & hostmon

I get that wherever I improperly set AF_INET and/or SOCK_STREAM.  I
haven't got the time but you might want to check the code to see if
this was numerically defined somewhere.  Solaris has a different value
for a tcp stream connection.

Tue, 2 Feb 1999, Keith Libitz

> My apologies if this has already been hashed out.
> I read through the archives and worked out my other
> issues but I can't seem to clear this final hurdle.
> When I run the hostmon-client on my Solaris 2.6 machine
> everything goes fine until it attempts to set up the 
> telnet daemon when I get the following:
> $ ./hostmon-client
> OSTYPE : SunOS 5.6 sun4u
> Loading File : hostmon-client.solaris2
> 27574
> $ socket() call failed: Protocol not supported
> What am I missing?
> Any help is greatly appreciated!
> Regards,
> Keith

Thank you,

Jonathan A. Zdziarski
Sr. Systems Administrator
Netrail, inc. 
888.NET.RAIL x240